ConfigMgr – In-Place Upgrade of SQL from 2012 to 2016

Hi,
today I did an In-Place Upgrade of my SQL Installation from SQL 2012 to the 2016 Release which is also supported by System Center Configuration Manager Current Branch (1606).
Everything went fine except the Report Service, I received the following errors within the upgrade:
Action required:
The upgrade process for SQL Server failed. Use the following information to resolve the error, and then repair your installation by using this command line: setup /action=repair /instancename=MSSQLSERVER

Feature failure reason:
An error occurred during the setup process of the feature.

Error details:
§ Error installing SQL Server Reporting Services
A HTTPS sertificate is not configured on the Web site.
Error code: 0x80131500
Visit http://go.microsoft.com/fwlink?LinkId=20476&ProdName=Microsoft+SQL+Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=13.0.1601.5&EvtType=0x589E8944%400x8285294C&EvtType=0x589E8944%400x8285294C to get help on troubleshooting.

TITLE: Microsoft SQL Server 2016 Setup
------------------------------

The following error has occurred:

The Report Server WMI provider cannot create the virtual directory. This error occurs when you call SetVirtualDirectory and the UrlString is already reserved. To continue, clear all URL reservations by calling RemoveURL and then try again.

For help, click: http://go.microsoft.com/fwlink?LinkID=20476&ProdName=Microsoft%20SQL%20Server&EvtSrc=setup.rll&EvtID=50000&ProdVer=13.0.1601.5&EvtType=0x589E8944%25400x9A8ECB73

And within ConfigMgr, the srsrp.log showed up with the following errors:
sql_update01

The request failed with HTTP status 503: Service Unavailable. SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
(!) SRS not detected as running SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
STATMSG: ID=7403 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_SRS_REPORTING_POINT" SYS=hosebeisccm01.deheim.hosebei.ch SITE=S01 PID=2808 TID=5420 GMTDATE=Sa Sep 24 19:13:20.480 2016 ISTR0="hosebeisccm01.deheim.hosebei.ch" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0 SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
Failures reported during periodic health check by the SRS Server hosebeisccm01.deheim.hosebei.ch. SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
Registry change SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 24.09.2016 21:13:20 5420 (0x152C)
Timed Out... SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Set configuration SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Check state SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Check server health. SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Successfully created srsserver SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Reporting Services URL from Registry [https://hosebeisccm01.deheim.hosebei.ch/ReportServer/ReportService2005.asmx] SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
The request failed with HTTP status 503: Service Unavailable. SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
(!) SRS not detected as running SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Failures reported during periodic health check by the SRS Server hosebeisccm01.deheim.hosebei.ch. SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Registry change SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 24.09.2016 21:14:20 5420 (0x152C)
Timed Out... SMS_SRS_REPORTING_POINT 24.09.2016 21:15:21 5420 (0x152C)
Set configuration SMS_SRS_REPORTING_POINT 24.09.2016 21:15:21 5420 (0x152C)

After some research it seemed to be the best option to go as follows:
1. Uninstall Report Services
2. Reboot Server
3. Reinstall Report Services
4. Configure Report Services
5. Reinstall the Report Service Role in ConfigMgr

But this did not solve the issue, and the srsrp.log did show another error:
sql_update02

Set configuration SMS_SRS_REPORTING_POINT 24.09.2016 21:35:25 5348 (0x14E4)
Check state SMS_SRS_REPORTING_POINT 24.09.2016 21:35:25 5348 (0x14E4)
Check server health. SMS_SRS_REPORTING_POINT 24.09.2016 21:35:25 5348 (0x14E4)
Successfully created srsserver SMS_SRS_REPORTING_POINT 24.09.2016 21:35:25 5348 (0x14E4)
Reporting Services URL from Registry [https://hosebeisccm01.deheim.hosebei.ch/ReportServer/ReportService2005.asmx] SMS_SRS_REPORTING_POINT 24.09.2016 21:35:25 5348 (0x14E4)
System.Web.Services.Protocols.SoapException: The feature: "Scale-out deployment" is not supported in this edition of Reporting Services. ---> Microsoft.ReportingServices.Diagnostics.Utilities.OperationNotSupportedException: The feature: "Scale-out deployment" is not supported in this edition of Reporting Services.~ at Microsoft.ReportingServices.Library.ReportingService2005Impl.GetItemType(String Item, ItemType& Type)~ at Microsoft.ReportingServices.WebServer.ReportingService2005.GetItemType(String Item, ItemTypeEnum& Type) SMS_SRS_REPORTING_POINT 24.09.2016 21:35:37 5348 (0x14E4)
(!) SRS not detected as running SMS_SRS_REPORTING_POINT 24.09.2016 21:35:37 5348 (0x14E4)
Failures reported during periodic health check by the SRS Server hosebeisccm01.deheim.hosebei.ch. SMS_SRS_REPORTING_POINT 24.09.2016 21:35:37 5348 (0x14E4)
Registry change SMS_SRS_REPORTING_POINT 24.09.2016 21:35:37 5348 (0x14E4)
Waiting for changes for 1 minutes SMS_SRS_REPORTING_POINT 24.09.2016 21:35:37 5348 (0x14E4)
Timed Out... SMS_SRS_REPORTING_POINT 24.09.2016 21:36:37 5348 (0x14E4)

I then opened the “Report Services Configuration Manager” Console and simply deleted the encryption content:
sql_update03

Afterwards the Report Services were installed from ConfigMgr successfully, even my self-created Reports were back there.

Hope this helps.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s